Pluto's World Documentation > Galaxy Bot > Requirements

Requirements

PlutoTheDev

Galaxy Bot is a Node.Js based application and requires a server (VPS or Dedicated) to operate.

As Galaxy Bot is a Node.Js operating application it requires a little more power than you might be used to with a more common site. This article covers some more specific details on what you need to run Galaxy Bot.

What do you need?

To have the ability to have Galaxy Bot running using our installation guide it's recommended to use the following.

  • Server (This can be a VPS or Dedicated machine, Ubuntu is recommended)

  • Discord Account

System Requirements

These are the minimum and recommended requirements for your system to have to host Galaxy Bot.

Minimum Recommended
OS: Ubuntu 18.04 LTS
Processor: 1 CPU Core
Memory: 2GB
Storage: 25GB
OS: Ubuntu 20.04 LTS
Processor: 3 CPU Cores
Memory: 6GB
Storage: 50GB

These specs may vary and be higher or lower, depending on things like traffic and other general resource usages.



Was this article helpful?

120 out of 12037 found this helpful